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Creating a Personal Web PageCreating a Personal Web PageCreating a Personal Web PageCreating a Personal Web Page    

As an educator or administrator you are always looking for new and exciting ways to 
communicate with students and others in an easy to use, cost effective, and efficient 
manner. The World Wide Web satisfies all these criteria and allows almost instant 
delivery of information, virtually anywhere. You can create a reference page with links 
and a course calendar, or you can create an entire online course. FrontPage 2000 
allows you to easily create and maintain Web pages suited to your needs without 
having to know any HTML. 

In this hands-on session, you will learn how to create a personal Web site. You will 
learn how to use templates to create your site, add hyperlinks, insert graphics, and 
upload your web pages to the web server.  

Before You BeginBefore You BeginBefore You BeginBefore You Begin    

Microsoft® FrontPage® is a Web site authoring and management program. It has 
many powerful features, yet it is still easy to master. 

FrontPage permits easy creation and modification of individual Web pages. However, 
note that some advanced FrontPage features require extensions, which currently are 
not supported at Cuesta College. Nevertheless all features necessary to develop a 
fully functioning website are available.  

You can easily test your Web pages by previewing them in your favorite browser. 
When you are ready to publish your creation to a live Web server, simply click the 
Publish button and specify the server you want to use. 

Request Web AccessRequest Web AccessRequest Web AccessRequest Web Access    

Prior to publishing your web page(s), you need to request space on the Cuesta web 
server by submitting a “Request for Web Update Access” sheet. You may obtain this 
form from your instructor, or by visiting 
http://www.cuesta.edu/deptinfo/compserv/Forms.htm and printing the document in 
either PDF or Word format. Once you complete and sign the form, have your Division 
Chair, Department Head or Committee Chair approve the form by signing. Finally, 
forward the approved form to Computer Services. After you have been allocated 
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space on the web server, an email will be sent from Computer Services with 
instructions and templates attached. 

Create a Folder for Web FilesCreate a Folder for Web FilesCreate a Folder for Web FilesCreate a Folder for Web Files    

Since you may wish to later access work done in this class, files should be saved to 
your personal drive (P:). To create a web folder on drive P:, perform the following: 

1. Launch My Computer.  
The “My Computer” window will open, displaying available drives. 

2. Under “Network Drives”, double-click on drive P: 
The contents of drive P: will be displayed. 

3. From the menu bar, select File > New > Folder. 
A “New Folder” will be displayed, with the name “New Folder” 
highlighted. 

4. Type “My Web” and press [Enter]. 
The new folder will be renamed “My Web”. 

Copy Template Files to P:Copy Template Files to P:Copy Template Files to P:Copy Template Files to P:    

To copy the template files to “My Web” on P:, perform the following: 

1. Launch My Computer. 
The “My Computer” window will open, displaying available drives. 

2. Under Address, select the drop-down list button. 

3. Scroll up and select Desktop from the drop-down list. 
The contents of the Desktop will be displayed. 

4. Open the folder, “FrontPage”, by double-clicking on it. 
Four files will be displayed; fac_template.htm, link_template.htm, 
jon.jpg, and banr.gif. 

5. Select all the files by pressing [Ctrl]-[A]. 
All four files will be selected. 

6. Copy all the files by pressing [Ctrl]-[C]. 

7. Under Address, select the drop-down list button. 

8. Scroll down and select P: from the drop-down list. 
The contents of drive P: will be displayed. 

9. Double-click on the directory, “My Web”. 
The empty folder, “My Web”, will be displayed. 

10. Paste the copied files by pressing [Ctrl]-[V]. 
The four copied files will appear. 
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Designing a Web PageDesigning a Web PageDesigning a Web PageDesigning a Web Page    

What attributes make for a good faculty web page? 

Plan Content Based on Audience NeedsPlan Content Based on Audience NeedsPlan Content Based on Audience NeedsPlan Content Based on Audience Needs    

The first thing to consider is your audience; whether students, co-faculty or others. 
What information do they want to see? What information do they not wish to see? 
Before you consider organization of your web page, think about the content. 

Keep it Simple and EasyKeep it Simple and EasyKeep it Simple and EasyKeep it Simple and Easy    

Put the most important information, like contact data, on the first (“home”) page. 
Save details for secondary pages that can be accessed from the home page. 

Widen Your Audience with 508 ComplianceWiden Your Audience with 508 ComplianceWiden Your Audience with 508 ComplianceWiden Your Audience with 508 Compliance    

Section 508 of the Rehabilitation Act requires that electronic information is 
accessible to people with disabilities. The mandate has several specific things to 
consider when designing a web site. However, the concepts areas follows: 

• Add “alt” tags to graphic (“non-text”) elements for the visually impaired 

• Include text with audio for the hearing impaired 

• Keep text clear and simple for the learning disabled, ESL folks and young 
users 

• Keep file sizes small for those using older (slower) technology. 

Keep Graphics Small and RelevantKeep Graphics Small and RelevantKeep Graphics Small and RelevantKeep Graphics Small and Relevant    

Graphics can spice up a web page. The can also (painfully) slow the time it take your 
audience to download your information. 

• Use graphic editing programs like Photoshop to keep the graphic as small in 
size (bytes) as possible. 

• Keep the number of graphics to a minimum. 

• Be consistent with your graphics. 

• Only use graphics when they truly enhance communicating important ideas. 

 



Revised: August 15, 2005  Page 4 

Other IdeasOther IdeasOther IdeasOther Ideas    

Jot down you own design ideas for ways to improve your web site: 

 

 

 

 

 

 

 

 

 

 

 

Touring FrontPageTouring FrontPageTouring FrontPageTouring FrontPage    

Before you start developing your own Web pages, become familiar with the features 
of FrontPage. The following illustration shows the Navigation view:  
 

 

Words to know: 
 
Browser————A program 
that allows you to 
view HTML formatted 
documents (like 
Microsoft® Internet 
Explorer). 
 
HTML————HyperText 
Markup Language. 
The language used to 
format web pages. 
 
Microsoft® 
FrontPage 2000—The 
latest version of 
Microsoft’s Web 
authoring and 
management program 
used to create and 
manage Web sites 
and pages with no 
knowledge of 
programming in 
HTML. Provides 
Seamless integration 
with the Microsoft 
Office family of 
applications. 
 
Microsoft® Internet 
Explorer 5.0—Is the 
latest version of 
Microsoft’s popular 
web browser. It allows 
editing and displaying 
of Web pages and 
collaboration on 
standard office 
documents through 
discussions and 
round tripping. 
 
Threaded 
Discussions—A Web 
page feature that 
allows individuals to 
have a topic based 
discussions 
 
URL—Uniform 
Resource Locator is 
the name and 
location of a file or 
web page. 
 
World Wide Web———— 
The collection of 
interconnected 
computers on the 
Internet. 
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Using The Faculty TemplateUsing The Faculty TemplateUsing The Faculty TemplateUsing The Faculty Template    

This section describes how to quickly create a personal Web site to share instructor 
and class information. You will use a template, modify it, and then save your web 
page in your directory on the P: drive. 

The following illustration shows the dialog box when selecting Open Web for the first 
time: 

 

    

To copy the faculty template as your home pageTo copy the faculty template as your home pageTo copy the faculty template as your home pageTo copy the faculty template as your home page    

1. Start FrontPage. 

2. On the File menu, click Open Web.  
The Open Web dialog box will appear. 

3. Select the “My My My My WebWebWebWeb” folder on drive P:P:P:P:, then click OpenOpenOpenOpen. 
If this is the first time opening “My Web” with FrontPage, the “Add 
FrontPage Information to the Folder” dialog box will appear. Click YesYesYesYes 
permitting FrontPage to set up the “My Web” folder. 

4. If necessary, on the VVVViewiewiewiew menu, click Folder ListFolder ListFolder ListFolder List. 
The Folder List pane should be visible. 

5. Double-click on the file, fac_template.htmfac_template.htmfac_template.htmfac_template.htm. 
The page will open in the view pane. 

6. On the FileFileFileFile menu, click Save AsSave AsSave AsSave As. 
The Save As dialog box will appear. 

7. In the Filename:Filename:Filename:Filename: field, type “index.htm” and click SaveSaveSaveSave. 

You can now add your own information to the page created and even create 
additional pages as necessary.  

    
You can test your 
Webs on your own 
computer before you 
publish them to a 
Web server. 
However, anything 
that requires server 
functionality will not 
be available. 

 
 
The icon for 
index.htmindex.htmindex.htmindex.htm (a house) 
is different than 
other FrontPage 
icons. “Index.htm” is 
a reserved name for 
the “home page” of a 
web site. If a user 
enters a web 
address without 
specifying a web 
page on that site, the 
home page 
(index.htm) will open 
by default. 

 

 
When naming web 
pages (or any other 
files used on your 
Web site), a good 
“rule of thumb” is to 
always use lowercase use lowercase use lowercase use lowercase 
lettersletterslettersletters, and avoid 
uppercase, spaces 
and other special 
characters. Some web 
browsers are case 
sensitive. 
 



Revised: August 15, 2005  Page 6 

To create a new page using the link_templateTo create a new page using the link_templateTo create a new page using the link_templateTo create a new page using the link_template    

1. In the Folder List pane, double-click on the file, linklinklinklink_template.htm_template.htm_template.htm_template.htm. 
The page will open in the view pane. 

2. On the FileFileFileFile menu, click Save AsSave AsSave AsSave As. 
The Save As dialog box will appear. 

3. In the Filename:Filename:Filename:Filename: field, type a unique name for this page and click SaveSaveSaveSave. 
Example: You could name the page “classes.htm” and later add class 
schedule information. 

To To To To create a new page using FrontPage templatescreate a new page using FrontPage templatescreate a new page using FrontPage templatescreate a new page using FrontPage templates    

1. On the tool menu, click the drop-down list button  to the right of the 

New button , and then click Page.  
The Page Templates dialog box will appear. 
 

 
 

 

2. From the Page Templates screen, double-click on the desired template. 
A new page based on the template will appear. 

 

Importing TextImporting TextImporting TextImporting Text    

If you already have text saved in a file you want to use on a web page, there’s no 
ned to retype it. Simply import the file. 

1. Open a new web page or, in an existing page, position the insertion point 
where you wish to insert the text. 

 
You can create a 
customized theme for 
your institution using 
the ”modify” button in 
the themes dialogue 
box. 
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2. From the menu bar, select InsertInsertInsertInsert > File…File…File…File… 
The Select File dialog box will appear. 

3. At the Select File screen, change “Files of type” to “All Files (*.*)All Files (*.*)All Files (*.*)All Files (*.*)” 

4. Locate the file containing the text you wish to import and click OpenOpenOpenOpen. 
The text will appear in the web page. 

 

 

Using TablesUsing TablesUsing TablesUsing Tables    

In webs, tables provide a means of dividing some or all of a page into rows and 
columns. Tables can be used to display tabular data as well as to simply position 
information on a page, perhaps with a border around it. FrontPage has an 
extensive capability for creating and working with tables. 

Tables are created by use of either the Insert Table button in the toolbar (which 
allows you to set the number of rows and columns in the table) or the Insert 
option on the Table menu, which opens the Insert Table dialog box. This dialog 
box allows you to specify the size, layout, and width of the table you are creating. 
Once a table is created, you can modify it through the table’s context menu, 
which appears when you can right-click the table. From the menu, you can 
choose Table Properties to change the overall properties of the table, or Cell 
Properties to change the properties of a single cell. 

To insert a row in a tableTo insert a row in a tableTo insert a row in a tableTo insert a row in a table    

1. Position the insertion point near where you want to insert a row.  

2. On the Table menu, point to Insert, and then click Rows or Columns.  

3. Click Rows, type the number of rows to insert.  

4. Under Location, specify where you want to place the rows. 
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To delete a row in a tableTo delete a row in a tableTo delete a row in a tableTo delete a row in a table    

1. Position the insertion point in the cell that's within a row you want to 
delete.  

2. On the Table menu, point to Select, and click Row.  

3. Right-click on the row, and then click Delete Cells on the shortcut menu.  

To delete a cell in a tableTo delete a cell in a tableTo delete a cell in a tableTo delete a cell in a table    

1. Position the insertion point in the cell you want to delete.  

2. On the Table menu, point to Select, and click Cell.  

3. Right-click on the cell, and then click Delete Cells on the shortcut menu.  

To split a cell in a tableTo split a cell in a tableTo split a cell in a tableTo split a cell in a table    

1. Position the insertion point near where you want to insert a row.  

2. On the Table menu, select Split Cells. 
The Split Cells dialog box will appear. 

3. Select “Split into ColumnsSplit into ColumnsSplit into ColumnsSplit into Columns” or “Split into RowsSplit into RowsSplit into RowsSplit into Rows”, specify how many 
column or rows, then click OKOKOKOK.  

To modify cell propertiesTo modify cell propertiesTo modify cell propertiesTo modify cell properties    

1. In Page view, select the cells for which you want to change the 
properties.  

2. Right-click, and then select Cell Properties from the shortcut menu.  

3. Do one or more of the following: 

o Set the alignment for the contents of the cell 

o Set cells as header cells 

o Prevent wrapping text in a cell 

o Adjust cell width or height by setting the number of rows or columns 
that it spans 

o Set cell borders 



Revised: August 15, 2005  Page 9 

Inserting GraphicsInserting GraphicsInserting GraphicsInserting Graphics    

Inserting graphics in FrontPage is as simple as positioning the insertion point 
and selecting Insert > Picture. However, be forewarned that large graphics can 
take up a tremendous amount of storage and can result in extremely slow 
downloading of your web pages. The rule of thumb is to use minimal graphics 
and keep them as small as possible. 

To replace existing graphic with anotherTo replace existing graphic with anotherTo replace existing graphic with anotherTo replace existing graphic with another    

1. In FrontPage, open the page containing the graphic you want to replace. 

2. Select the graphic. 
”Handles” should appear on the corners and midsections of the 
selected graphic. 

3. In the Insert menu, point to Picture, and then click From File.  
The Picture dialog box will appear. 

4. Select the replacement graphic file and click Insert. 
The new graphic will replace the old. 

To add an “alt” tag to a graphic imageTo add an “alt” tag to a graphic imageTo add an “alt” tag to a graphic imageTo add an “alt” tag to a graphic image    

1. In FrontPage, right-click on the image. 
A shortcut menu will appear. 

2. From the shortcut menu, select Picture PropertiesPicture PropertiesPicture PropertiesPicture Properties. 
The Picture Properties dialog box will appear. 

3. Select the GeneralGeneralGeneralGeneral tab.  

4. Enter descriptive text in the Text field, and then click OKOKOKOK. 

 

 
 
If you have a large 
graphic, do not 
attempt to resize it in 
FrontPage! The 
graphic will appear 
smaller, but the file 
will actually maintain 
its original size.  
 
Instead, resize 
graphics using a 
graphic editing 
program like 
Photoshop Elements. 

 

 
 
Make sure the 
replacement graphic 
is approximately the 
same size as the 
original.  
Example, if replacing 
the photo in 
“index.htm”, make 
sure the replace-
ment graphic is 
approximately 200 
pixels wide.  
 

General tab 

(step 3) 

Text field 

(step 4) 
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Applying HyperlinksApplying HyperlinksApplying HyperlinksApplying Hyperlinks    

In Page view you can add hyperlinks (or links), which allow the user of a web to 
quickly jump to another page, or to a particular location on the same or different 
page (called a bookmark), or to a different web or web site. Links can applied to 
either text or a picture, and you can map certain areas of a picture with different 
links (called hotspots).  

You create a link by first selecting the object to which you want to apply the link 
and then clicking the Hyperlink button in the toolbar (or by choosing Hyperlink 
from the Insert menu). In either case, the Create Hyperlink dialog box will open. 
Within the Create Hyperlink dialog box, you can select any page in the current 
web, a bookmark on any open page, or any URL or address on the World Wide 
Web. When you have created a hyperlink, the object on which the user is to click 
changes to a different color and may become underlined. 

A picture can have its entire area defined as a link, or you can identify specific 
areas in a picture as separate links, while any unidentified areas are assigned a 
default link. For example, you could provide a map that allows the user to quickly 
get to information about a particular area of the world by simply clicking that 
area. 

To apply a link to text or graphicTo apply a link to text or graphicTo apply a link to text or graphicTo apply a link to text or graphic    

1. In FrontPage, open the page containing the element to which you want 
to apply a hyperlink. 

2. Select the text or graphic. 

3. Right-mouse click on the selection. 
A shortcut menu will appear. 

4. Select HyperlinkHyperlinkHyperlinkHyperlink from the shortcut menu. 
An Insert Hyperlink dialog box will appear. 

5. Under Link toLink toLink toLink to, click Existing File or Web PageExisting File or Web PageExisting File or Web PageExisting File or Web Page. 

6. Select the page where you want to link to, or type in  
the URL (web address) of any page currently on the internet. 

7. Click OKOKOKOK. 
 

 

 

 

 

 

    
Most hyperlinks can be 
tested while in 
FrontPage’s Page 
Normal view. Just hover 
the mouse pointer over 
the linked element and 

[Ctrl][Ctrl][Ctrl][Ctrl]----clickclickclickclick. 

“Existing File 
or Web Page” 
(step 5) 

list of local pages 
and elements 
(step 6) 

URL or web 
address  
(step 6) 
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To apply a hotspot to a graphicTo apply a hotspot to a graphicTo apply a hotspot to a graphicTo apply a hotspot to a graphic    

1. In FrontPage, open the page containing the graphic to which you want to 
apply a hotspot. 

2. Select the graphic. 
The Pictures toolbar will appear. 

3. On the Pictures toolbar, click the Hotspot button corresponding to the 
shape you want:  

o Rectangular Hotspot  

o Circular Hotspot  

o Polygon Hotspot  

4. On the graphic, draw a rectangle, circle, or polygon, depending on the 
shape you chose while holding down the mouse button. 
When you release the mouse button, the Insert Hyperlink dialog box will 
appear.  

5. Under Link toLink toLink toLink to, click Existing File or Web PageExisting File or Web PageExisting File or Web PageExisting File or Web Page. 

6. Select the page where you want to link to, or type in the URL (web 
address) of any page currently on the internet. 

7. Click OKOKOKOK. 
 

TTTTo create an eo create an eo create an eo create an e----mail linkmail linkmail linkmail link    

1. Select either text or a picture/graphic. 

2. Right-mouse click on the selection. 
A shortcut menu will appear. 

3. Select HyperlinkHyperlinkHyperlinkHyperlink from the shortcut menu. 
An Insert Hyperlink dialog box will appear. 

4. Under Link to, click the E-mail Address button. 

5. Either type the e-mail address you want in the “E-mail address” box, or 
select an e-mail address in the “recently used e-mail addresses” box. 

6. If desired, type the subject of the e-mail message in the Subject box. 

(see illustration on next page) 

 

 

    
Note: To display the 
Pictures toolbar, point 
to ToolbarsToolbarsToolbarsToolbars on the ViewViewViewView 
menu, and then click 
PicturesPicturesPicturesPictures. 
 

    
Note: To draw a 
polygon, click where 
you want the first 
corner of the polygon to 
be, click to place each 
corner of the polygon, 
and then double-click 
to finish it. 
 

    
Note: When creating an 
e-mail link, if you do not 
select text or a picture, 
the destination e-mail 
address and subject 
are displayed as the 
hyperlink text. 
 

    
Note: Some Web 
browsers and e-mail 
programs may not 
recognize the subject 
line of an e-mail link. 
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Publishing To The Web ServerPublishing To The Web ServerPublishing To The Web ServerPublishing To The Web Server    

A web site is a group of files that are interconnected by hyperlinks that allow you 
to jump from one page to another, usually by clicking your mouse. While it's 
possible for a web site to be a single HTML page, a web site usually comprises 
several pages that can include images, hyperlinks, and more advanced 
technology like forms and databases. Publishing a web site generally means 
copying all of the files that make up a web site to a particular destination.  

In Microsoft FrontPage, you would typically publish your site when you want to: 

o Make your site (or changes to your site) available for public viewing  

o Make a backup of your site  

By using the FrontPage Publish Web command, you can choose to publish all the 
files in your web site or only the ones that have been changed. You can also 
individually choose which files you want to publish. 

The first time you use the Publish Web command, you must configure it by 
entering information like server location, user ID, etc. 

To conTo conTo conTo configure Publish Webfigure Publish Webfigure Publish Webfigure Publish Web    

1. Start FrontPage and, if necessary, open your web (on P:/My Web). 

2. On the FileFileFileFile menu, click Publish WebPublish WebPublish WebPublish Web. 
The Publish Destination dialog box will be displayed. 

3. Click the Browse    button. 
The New Publish Location dialog box will be displayed. 

4. In the Look InLook InLook InLook In drop-down list box, select Add/Modify FTP LocationsAdd/Modify FTP LocationsAdd/Modify FTP LocationsAdd/Modify FTP Locations. 
The Add/Modify FTP Locations dialog box will appear. 

5. Enter the necessary information in the Add/Modify FTP LocationsAdd/Modify FTP LocationsAdd/Modify FTP LocationsAdd/Modify FTP Locations dialog 
box: 

a. In the Name of FTPName of FTPName of FTPName of FTP site site site site field, enter: 
academic.cuesta.edu. 

    
Prior to publishing your 
web page(s), you need 
to request space on the 
Cuesta web server by 
submitting a “Request Request Request Request 
for Web Update for Web Update for Web Update for Web Update 
AccessAccessAccessAccess” sheet. You may 
obtain this form by 
visiting 
http://www.cuesta.edu
/deptinfo/compserv/ 
Forms.htm and printing 
the document in either 
PDF or Word format. 
Once you complete and 
sign the form, have 
your Division Chair, 
Department Head or 
Committee Chair 
approve the form by 
signing. Finally, forward 
the approved form to 

Computer Services.  

    
Configuration of Publish 
Web need only be done 

once for a new web.  

E-mail address 
(step 5) 

Recently used 
e-mail address 
(step 5) “E-mail 

Address” button 
(step 4) 

Subject box 
(step 6) 
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b. Under Log On AsLog On AsLog On AsLog On As, choose UserUserUserUser 

c. Enter your user ID (first initial-last name) in the UserUserUserUser field. 

d. Enter your password in the PasswordPasswordPasswordPassword field. 

6. Click AddAddAddAdd, and then click OKOKOKOK. 
The New Publish Location dialog box will appear 

7. Select “ftp://academic.cuesta.edu” and click OpenOpenOpenOpen. 
The Publish Destination dialog box will be displayed with the academic 
server location and your user ID listed (i.e. 

“ftp://academic.cuesta.cuesta/%2fuserid”) 

IMPORTANT: If the displayed destination path is lacking your user ID 
(i.e. “ftp://academic.cuesta.edu/%2f”),  

appendappendappendappend your user ID after the characters “%2f”.  

(Example: “ftp://academic.cuesta.edu/%2fuserid”.) 

8. At the Publish Destination dialog box, click OKOKOKOK. 
The Publish Web dialog box will appear, listing your web elements and 
their status. 

9. Verify the status of your web elements, and then click PublishPublishPublishPublish. 
Your web elements will be uploaded to your directory on the Cuesta web 
server. 

To publish to the Cuesta “academic” server (after To publish to the Cuesta “academic” server (after To publish to the Cuesta “academic” server (after To publish to the Cuesta “academic” server (after 
configuration)configuration)configuration)configuration)    

1. Start FrontPage and, if necessary, open your web (on P:/My Web). 

2. On the FileFileFileFile menu, click Publish WebPublish WebPublish WebPublish Web. 
The Publish Destination dialog box will be displayed. 

3. At the Publish Destination dialog box, click OKOKOKOK. 
The Publish Web dialog box will appear, listing your web elements and 
their status. 

4. Verify the status of your web elements, and then click PublishPublishPublishPublish. 
Your web elements will be uploaded to your directory on the Cuesta web 
serve. 

Getting HelpGetting HelpGetting HelpGetting Help    

You can get help at any time while you are using FrontPage. To open the Office 
Assistant, click the FrontPage Help button on the Standard toolbar. To open the 
online Help, on the Help menu click Microsoft FrontPage Help. If you have an 
Internet connection, you can also point to Office on the Web on the Help menu and 
choose from several resources that may be of interest to you such as Product News, 
Frequently Asked Questions, and    Online Support. Don’t forget to go to 
www.microsoft.com/frontpage for all the latest information. 

    
IMPORTANT!  
Each time you start 
FrontPage and then 
Publish, you will be 
prompted to log on to 
the FTP server. 
Additional attempts to 
Publish during that 
session will not result in 

log on prompts. 


