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Installing the Grade Book Template 
 

1. Locate the “T3 – Tech Tips & Training” channel in myCuesta (usually on the Work Life 
tab). 

 
2. Click Tips & Training Links . 

An expanded list will appear. 
 

3. Click Training and How-to Materials . 
A Training Materials window will appear. 

 
4. Click Grade Book Template  under the 

category, Excel. 
A dialog box will appear. 

5. Click the “Save” button. 
The Save As dialog will appear. 

 

6. Select “Desktop ” in the “Save in” field,  
then click the “Save” button.  
The Download complete dialog may appear. 

 

7. Click the “Open” button.  
Excel will launch and the  
grade book template will open.  

8. From Excel’s menu bar,  
select File > Save As…  
The Save As dialog box will appear.  

9. Change the Save As Type  to “Template (.xlt) ”. 
The Save In field should read “Templates”. 

 

10. Click “Save”. 
The file, “GradeBookTemplate4Banner.xlt”, 
 will be saved in the Templates directory. 

11. From the Excel menu bar, select File > Close .  
The grade book template will close. 

 

 
 

NOTE: Once you have saved the template in Excel, you 
may delete it from your Desktop. 

IMPORTANT: If Save In (top of the dialog) does 
not read “Templates”, change the Save As Type 
(bottom of the dialog) to “Excel Workbook” and 
then change back to “Template”. 
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Creating the Grade Book 
 

1. From the Excel menu bar, select File  > New. 
A “New Workbook” pane will appear in the Task Pane on the far right. 

 

2. Select “On my computer… ” under the Templates heading in the 
New Workbook task pane. 
The Templates dialog box will appear. 

 

3. Select the template, 
GradeBookTemplate4Banner.xlt . 

 

4. Click the OK button. 
A new worksheet will open based on the 
selected 
 template. 

 

5. Select File  > Save from the menu bar. 

 

6. Give the grade book a meaningful name (i.e. the name of the course+semester+year) 
and select where to save the grade book. Then click the Save button. 

 

 

Pasting the Roster into the Grade Book 
These instructions assume you have already downloaded your class roster to the Desktop.  
 

1. Open the downloaded roster: 

a. Select File  > Open  from the Excel menu bar. 
The Open dialog box will appear. 

b. Click the drop down list button under “Look 
In”, and select “Desktop ”. 
The downloaded class roster will  
appear in the file list above. 

c. Double-click  on the downloaded class roster 
(XLS) file to open it. 
An Import Wizard screen may appear. 

d. If an Import Wizard screen appears, click the 
Finish  button.  
The class roster will open as a new workbook in 
Excel. 
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2. Copy the roster information: 

a. Click once on any cell in the roster containing information. 
Do not click in a blank cell. 

b. Press [Ctrl] -[A]  to select all of the text, and then press [Ctrl] -[C]  to copy that selected text. 
The downloaded class roster will be copied. 

 

3. Paste the copied roster in the grade book: 

a. Select Window  from the menu bar, and click your grade book listed at the bottom of the 
menu. 
The Grade Book workbook will appear. 

b. Select the Student Info  worksheet by clicking on its tab at the bottom of the screen. 

c. Position the cell pointer in cell A1. 

d.  Press [Ctrl] -[V]  to paste the copied class roster.  
The ID should be in column E, the Last Name should be in column F, and the First Name should be in 
column G. The titles should appear in row 1 and the first student record should appear on row 2. If 
necessary, press Undo (to undo the paste) and repeat steps 3e and 3f. 

e. Select File  > Save from the menu bar. 

 

4. Close the roster: 

a. Select Window  from the menu bar and click the class roster listed at the bottom of the 
menu. 
The class roster workbook will appear, still selected with the “marching ants” (the marquee) surrounding 
the selection. 

b. Close the class roster workbook by selecting File  > Close  from the menu bar. 
 

 

 

 

 

 

Cleaning up the Student Info worksheet 
1. Adjust and hide columns on the Student Info worksheet: 

a. Select columns A-T on the Student Info tab of the grade book. 

b. Double-click between any two of the selected column selectors. 
The column widths will all automatically adjust. 

c. Hide unnecessary columns (i.e. A-D, I, M, R-T). 
See “Hiding Columns & Rows” on page 11. 

2. Select the "Computation Data " worksheet and enter the minimum percentage score for 
the grades. 

3. Save your grade book, by selecting File  > Save from the menu bar. 

 
 

NOTE: If a message appears reading…  

“There is a large amount of information on the Clipboard. Do you want to be able 
to paste this information into another program later?” 

…click the “No” button. 



Creating a Grade Book in Excel  Page 7 of 14 
Revised: September 28, 2009 

Assigning Student ID Numbers 
 
Since Cuesta College’s policy prohibits using the Banner ID numbers for identification within 
your grade book, the ID field on the Grade Sheet worksheet displays only the last 5 digits of the 
student’s Banner ID.  

 

If you wish to assign a different ID, consider the following suggestions: 

• A popular method of “generating” ID numbers is to allow the students to create their own. By 
doing so, it minimizes the chance that the student will forget their ID. It also permits the 
student to use the same ID for different classes. 

• To assign your own ID numbers to students, see “Generating ‘Random’ Student ID 
Numbers” on page 14. 

 

Entering Scores in the Grade Book 
 

1. Open  the grade book file. 

2. Select the Grade Sheet  worksheet by clicking on its tab at the bottom of the screen. 

3. Decide in which column you wish to record a grade. 
NOTE: If you need additional columns, see “Adding a Column…”, below. 

4. Select the cell in the first row (row 1) of the column and enter a Total Possible Points for 
that assignment/test.  

5. Select the cell in the second row (row 2) of the column and type a title for that 
assignment. (i.e. “Quiz, Week 4”, “Midterm Nov 3”, “Oral Report #3”, etc.) 

6. In the subsequent rows for that column enter the students’ scores. 
The students’ ongoing total scores and grade will appear to the right of the “Final” column. 

Tips:  
 

• Prior to data being entered in a worksheet, "errors"  reading "#DIV/0!" may appear in 
some fields. This is normal. 

 
• Do not  enter Total Possible Points prematurely!  Enter Total Possible Points (step 4) 

when you’re ready to enter student scores for that assignment. Entering Total Possible 
Points without the associated student scores will skew grades. 

 
• Use simple weighting by increasing the value of an assignment / test.  If a test is 

worth twice the value of another assignment, double the value of that test. For example, 
if essays are worth 20 points and quizzes are worth 50% more, then score quizzes 30 
points. (20 + 50% = 20 + 10) 

 
• The Grade Book Template has been set up for a maximum of 150 students . If you 

have fewer students than that you may just ignore unused rows. If you have a greater 
number of students than that, contact Computer Services for assistance in adding 
additional rows to your form. 
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Adding a Column to the Grade Book 
1. Right -mouse click  on the column selector above “Final”.  

The entire Final column will be highlighted and a shortcut menu will 
appear. 

2. Select Insert  from the shortcut menu. 
A new column will be inserted to the left of the Final column. 

 

Dropping Low Scores in the Grade Book 
The grade book permits manually dropping one or more low scores. When a 
low score is dropped, the Total Possible Points is not used in that student’s 
grade computation. 
 

1. Double-click on the cell with the score you wish to drop. 
Excel will be in edit mode, with the insertion point appearing in the selected cell. 

2. Change the student’s score to a negative number by placing a minus sign (-) before the 
cell entry. 
Example: If the student’s lowest score was “12”, change to “-12”. 

3. Press the [Enter ] key. 

 
IMPORTANT: In order for the drop-lowest-score to work, the value being dropped must be less 
than zero. Therefore if the lowest score is “0”, it is recommended that the value be changed to “-
1” and an explanatory comment be added to that cell. (See “Comments” below) 

 

Adding Students to Grade Book 

 
1. Open  the grade book file, and select the Student Info worksheet by clicking on its tab at 

the bottom of the screen. 

2. Append at the bottom of the list the student’s name and other information (as 
appropriate), entering the data in the proper columns. 
NOTE: Unnecessary information (i.e. Term, CRN, etc.) can be left blank. 

 

Student Info Worksheet Column Identification 

Column B C D E G H I J K L M 

Contents Term CRN Subject ID Last 
Name 

First 
Name 

MI Major Phone Cuesta 
e-mail 

Personal 
e-mail 

 

NOTE: Never  remove students (even those who drop the class) from the grade book! 
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Sorting Grade Sheet  

 
While sorting the Student Info worksheet should be avoided, sorting the Grade Sheet is 
encouraged. When sharing grades, the Grade Sheet should be sorted by ID number and 
student names hidden. When entering student scores, the student names should be “unhidden” 
and the Grade Sheet sorted by Last Name and then First Name. 

 

 
 
 

 
Important: Make sure the Grade Sheet worksheet is 
selected by clicking on its tab at the bottom of the screen. 

1. Starting with row 2  (the row with the column names), 
click and drag down the row headings (the row numbers 
on the far left), selecting all rows containing data. 

2. From the menu bar, select Data > Sort . 
The Sort dialog will appear. 

3. Sort the student data as desired: 

• To sort by Last Name and then First Name : 

a. Select “Header row ” under “My data range has”. 

b. In the “Sort by” field, select Last Name  from the 
drop-down list, and the Ascending  radio button. 

c. In the “Then by” field, select First Name  from the 
drop-down list, and the Ascending  radio button. 

d. Click OK. 
The data will be sorted by last name and then first name. 

 

• To sort by ID number : 

a. Make sure “Header row ” is selected under “My data 
range has”. 

b. In the “Sort by” field, select ID from the drop-down 
list, and the Ascending  radio button. 
NOTE: All other sort fields should be blank. 

c. Click OK. 

d. If a Sort Warning appears, click OK. 
The data will be sorted by ID. 

REMEMBER: Do not  sort the Student Info worksheet!  
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Sorting Attendance 
 
Periodically you may wish to sort the Attendance worksheet. This will assure that any students 
added to the Student Info worksheet will appear in correct (alphabetical) order on the 
Attendance worksheet.  

 

 
 
 

 
Important: Make sure the Attendance worksheet is selected by clicking on its tab at the 
bottom of the screen. 

 

1. Starting with row 1  (the row with the column 
names), click and drag down the row headings 
(the row numbers on the far left), selecting all 
rows containing data. 

 

 

 

 

2. From the menu bar, select Data > Sort . 
The Sort dialog will appear. 

3. Make sure “Header row ” is selected under “My data range 
has”. 

4. In the “Sort by” field, select Last Name  from the drop-down 
list, and the Ascending  radio button. 

5. In the “Then by” field, select First Name  from the drop-down 
list, and the Ascending  radio button. 

6. Click OK. 
The data will be sorted by last name and then first name. 

 

REMEMBER: Do not sort the Student Info worksheet!  
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Hiding Columns & Rows 
 
You can hide columns or rows to conceal the entries in them. For example, you may wish to: 

• Allow a student to see his/her grade information, while hiding the rows that contain other 
students’ data 

• Keep students’ names private by hiding those columns 

• Hide those columns of (future) scores which are currently empty 

Hidden columns and rows do not appear in the worksheet and do not print. Any number in a 
hidden column or row is still calculated while the column or row is hidden. 
 

1. Select the column(s) or row(s) you want to hide.  

2. Right-click one of the selected column(s) or row(s).  

3. Select the Hide  command. 

 
 
 
 
 
 
 
 
 

“Unhiding” Columns & Rows 
 
You can redisplay hidden columns and rows. For example, after meeting with a student in which 
confidential information was hidden, you can unhide the rows to continue your normal 
worksheet process. Unhidden columns and rows are reset to the column width or row height 
prior to being hidden. 
 

1. Select the columns or rows on both sides of the hidden columns or rows.  

2. Right-click one of the selected columns or rows.  

3. Select the Unhide  command. 

 
 
 
 
 

You can also hide a column or row by dragging the line to the right of a column 
heading or below a row heading until the column or row is sized to 0.00. 

When you are dragging to select columns or rows you want to hide, make sure 
that the mouse pointer is a white cross and not a black, double-headed arrow. 
The double-headed arrow is used for adjusting column width and row height. 

If you have hidden several non-adjacent ranges of rows or columns, you can use 
the Select All button to quickly select the total worksheet. You can then select the 
Unhide command from the row shortcut menu to display all rows or the column 
shortcut menu to display all columns. 
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Sharing Grades with Students (via PDF) 
 
By hiding students names (see “Hiding Columns and Rows”, page 10) and sorting by ID number 
(see “Sorting Grade Sheet”, page 9), grades can be safely shared with students via Course 
Studio or a personal website.  
 

1. Hide  any columns or rows you don’t wish displayed. (see “Hiding Columns and Rows”, 
above) 
Example: Hide student names and empty (“un-scored”) columns. 

2. Select  the portion of the worksheet you wish to share with your students. 

3. From the menu bar, select File  > 
Print .  
The Print dialog will appear. 

4. Select “PDFCreator ” from the Printer 
dropdown menu. 

5. Click Selection  in “Print Range”. 

6. Click the OK (or Print) button. 

 

 
 

 

 

 

After a few seconds the PDFCreator 
dialog will appear. 

 
7. Click the Save button. 
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A Save As dialog will appear. 

 
 

8. Select where you wish to 
save your PDF, using the 
“Save in” field at the top of 
the dialog. 

 
9. If you wish to rename your 

PDF, type a new name in 
the “File name” field. 

 
10. Click the Save button. 

An animated graphic will appear, indicating the file is being created. After a few moments, Adobe 
Reader (or Adobe Acrobat, depending on which you have installed on your computer) will launch 
displaying the converted PDF. 

  
11. Post the file in Course Studio or upload the file to your website. 

 

Comments 
Comments may be associated with a specific cell. For example, a comment might be added to a 
cell explaining why the score was dropped or changed. Cells with comments have a small red 
mark in the upper-right corner of the cell. Comments may be viewed by placing the mouse 
pointer over the cell. 

Adding a Comment 
1. Right-click on a cell.  

A shortcut menu will appear. 

2. Select Insert Comment . 
A comment box will appear. 

3. Type the comment. 

4. When finished typing, click outside the comment box. 

Deleting a Comment 
1. Right-click on a cell.  

A shortcut menu will appear. 

2. Select Delete Comment . 

 

NOTE: Use only letters and 
numbers in the file name, 
avoiding special characters. 
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Generating “Random” Student ID Numbers 
 
Cuesta College’s policy prohibits using the Banner ID numbers for identification within your 
grade book. For that reason, the ID field on the Grade Sheet worksheet displays only the last 5 
digits of the student’s Banner ID.  

Rather than using the partial Banner ID, some faculty prefer to allow the students to compose 
their own ID numbers (see “Assigning Student ID Numbers” page 6). Others may prefer to 
assign “randomly” generated numbers that the students can later use to identify their grades. 
The following are steps to do the latter. 

1. Open  the grade book file and select the Student Info worksheet by clicking on its tab at 
the bottom of the screen. 

2. Sort the student info by ID (instead of last name) so ID numbers you assign won’t be 
obvious. 

a. Click anywhere in the student data. 

b. From the menu bar, select Data > Sort . 
The student data will be highlighted and the Sort 
dialog will appear. 

c. In the “Sort by” field, select ID and click OK. 
The data will be sorted by ID.  
 

3. In cell E2, enter a starting number. (Example: 211) 

4. In cell E3, enter another number slightly larger than the 
first. (Example: 218) 

5. Select both cells E2 and E3 . 

6. Position the cell pointer over the Fill Handle (the black dot in the lower right corner of the 

selected range).  
The cell pointer will appear as a black cross. 

7. Drag the Fill Handle  straight down column E until all the Banner ID’s have been 
highlighted. 
When you release the mouse button, the ID’s will be replaced with numbers that increment based 
on the two numbers selected. 

8. Protect the Student Info worksheet to avoid accidental 
sorting in the future. 

a. From the menu bar, select Tools  > Protection  > 
Protect Sheet . 
The Protect Sheet dialog will appear. 

b. Click OK. 
The Student Info worksheet will be protected.  
 

 

 


